Back to overview
Degraded
Service Status: Operating on Backup Generators
Apr 27 at 09:45pm GMT-12
Affected services
Barcelona, Spain
Resolved
Apr 28 at 05:31am GMT-12
We are pleased to inform you that power has been fully restored to our Barcelona data center. Throughout the outage, our services continued without interruption, and all operations have returned to normal. We appreciate your patience and understanding during this incident.
Affected services
Barcelona, Spain
Created
Apr 27 at 09:45pm GMT-12
Due to a power outage in Spain, our Barcelona data center is currently running on backup generators. All services remain stable, and we have sufficient capacity to maintain operations for several hours. Our team is monitoring the situation closely and will provide updates as needed.
Thank you for your understanding,
Affected services
Barcelona, Spain